use strict;
my $str = 'abc123/';
my $regex = qr/^(?=.{64}2\)\?\.\*\\.{204}\\2\\\(\)\{2\}\.\{11\}\$\/$)((.*)(\2\2)?.*\/\2\^\2\(\2\?=\2\.\2\{64\2\}2\2\\\2\)\2\\\2\?\2\\\2\.\2\\\2\*\2\\\2\\\2\.\2\{204\2\}\2\\\2\\2\2\\\2\\\2\\\2\(\2\\\2\)\2\\\2\{2\2\\\2\}\2\\\2\.\2\\\2\{11\2\\\2\}\2\\\2\$\2\\\2\/\2\$\2\)\2\(\2\(\2\.\2\*\2\)\2\(){2}.{11}$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}