#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\[\[.+?)(\/)([^|\[\]]+?\]\])"
Local $sString = "[[Obsidian/Deep Links]] and [[Obsidian/Deep Links]]"
Local $sSubst = "$1#$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)