$re = '/(\[\[.+?)(\/)([^|\[\]]+?\]\])/m';
$str = '[[Obsidian/Deep Links]] and [[Obsidian/Deep Links]]';
$subst = "$1#$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;