package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:[a-z]+_and_)?(?P<superhero>[a-z]+man)(?:_and_[a-z]+)?(?:\s|$)`)
var str = `hemn_and_orkoman
superman
spiderman_and_villan
lizardman_fake_and_silly
butterflymanandroses
man
GucciMane
thelma_and_megaman
snakeman_and_dubious
amansquito_and_corner_case
aquaman`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}