// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?:[a-z]+_and_)?(?P<superhero>[a-z]+man)(?:_and_[a-z]+)?(?:\s|$)").unwrap();
let string = "hemn_and_orkoman
superman
spiderman_and_villan
lizardman_fake_and_silly
butterflymanandroses
man
GucciMane
thelma_and_megaman
snakeman_and_dubious
amansquito_and_corner_case
aquaman";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}