$re = '/(?:[a-z]+_and_)?(?P<superhero>[a-z]+man)(?:_and_[a-z]+)?(?:\s|$)/i';
$str = 'hemn_and_orkoman
superman
spiderman_and_villan
lizardman_fake_and_silly
butterflymanandroses
man
GucciMane
thelma_and_megaman
snakeman_and_dubious
amansquito_and_corner_case
aquaman';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);