import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[a-z]+_and_)?(?P<superhero>[a-z]+man)(?:_and_[a-z]+)?(?:\\s|$)";
final String string = "hemn_and_orkoman\n"
+ "superman\n"
+ "spiderman_and_villan\n"
+ "lizardman_fake_and_silly\n"
+ "butterflymanandroses\n"
+ "man\n"
+ "GucciMane\n"
+ "thelma_and_megaman\n"
+ "snakeman_and_dubious\n"
+ "amansquito_and_corner_case\n"
+ "aquaman";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}