use strict;
my $str = 'hemn_and_orkoman
superman
spiderman_and_villan
lizardman_fake_and_silly
butterflymanandroses
man
GucciMane
thelma_and_megaman
snakeman_and_dubious
amansquito_and_corner_case
aquaman';
my $regex = qr/(?:[a-z]+_and_)?(?P<superhero>[a-z]+man)(?:_and_[a-z]+)?(?:\s|$)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}