import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\s?([^\\{\\}\\s]*)\\s?\\}";
final String string = "{\n"
+ " \"outputKeys\":[\n"
+ " \"hello\"\n"
+ " ],\n"
+ " \"params\":{\n"
+ " \"username\":\"Анастасия\",\n"
+ " \"content\":\"вам пришли новые данные с бота\",\n"
+ " \"avatar\":\"https://twintwoo-prod-media.s3.amazonaws.com/9d491869817b7bdbaaed7ff7d139ff0a\",\n"
+ " \"embeds\":[\n"
+ " {\n"
+ " \"fields\":[\n"
+ " {\n"
+ " \"name\":\"Selected\",\n"
+ " \"value\":\"Форма\",\n"
+ " \"inline\":true\n"
+ " },\n"
+ " {\n"
+ " \"name\":\"Имя\",\n"
+ " \"value\":\"{name}\",\n"
+ " \"inline\":true\n"
+ " },\n"
+ " {\n"
+ " \"name\":\"E-mail\",\n"
+ " \"value\":\"{email}\",\n"
+ " \"inline\":true\n"
+ " }\n"
+ " ]\n"
+ " }\n"
+ " ]\n"
+ " },\n"
+ " \"headers\":{\n"
+ " \"Accept\":\"application/json\"\n"
+ " },\n"
+ " \"method\":\"POST\",\n"
+ " \"url\":\"https://discord.com/api/webhooks/788795281901879296/LPJVPl9UKdexDaVnarPZ3rxHVXXc8kci-7_xeYIfVITWg6Wg-yu9GZ-x7DxsYnpkvUmX\"\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}