$re = '/{\s?([^{}\s]*)\s?}/';
$str = '{
"outputKeys":[
"hello"
],
"params":{
"username":"Анастасия",
"content":"вам пришли новые данные с бота",
"avatar":"https://twintwoo-prod-media.s3.amazonaws.com/9d491869817b7bdbaaed7ff7d139ff0a",
"embeds":[
{
"fields":[
{
"name":"Selected",
"value":"Форма",
"inline":true
},
{
"name":"Имя",
"value":"{name}",
"inline":true
},
{
"name":"E-mail",
"value":"{email}",
"inline":true
}
]
}
]
},
"headers":{
"Accept":"application/json"
},
"method":"POST",
"url":"https://discord.com/api/webhooks/788795281901879296/LPJVPl9UKdexDaVnarPZ3rxHVXXc8kci-7_xeYIfVITWg6Wg-yu9GZ-x7DxsYnpkvUmX"
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);