use strict;
my $str = '{
"outputKeys":[
"hello"
],
"params":{
"username":"Анастасия",
"content":"вам пришли новые данные с бота",
"avatar":"https://twintwoo-prod-media.s3.amazonaws.com/9d491869817b7bdbaaed7ff7d139ff0a",
"embeds":[
{
"fields":[
{
"name":"Selected",
"value":"Форма",
"inline":true
},
{
"name":"Имя",
"value":"{name}",
"inline":true
},
{
"name":"E-mail",
"value":"{email}",
"inline":true
}
]
}
]
},
"headers":{
"Accept":"application/json"
},
"method":"POST",
"url":"https://discord.com/api/webhooks/788795281901879296/LPJVPl9UKdexDaVnarPZ3rxHVXXc8kci-7_xeYIfVITWg6Wg-yu9GZ-x7DxsYnpkvUmX"
}';
my $regex = qr/{\s?([^{}\s]*)\s?}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}