const regex = /{\s?([^{}\s]*)\s?}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{\\s?([^{}\\s]*)\\s?}', 'g')
const str = `{
"outputKeys":[
"hello"
],
"params":{
"username":"Анастасия",
"content":"вам пришли новые данные с бота",
"avatar":"https://twintwoo-prod-media.s3.amazonaws.com/9d491869817b7bdbaaed7ff7d139ff0a",
"embeds":[
{
"fields":[
{
"name":"Selected",
"value":"Форма",
"inline":true
},
{
"name":"Имя",
"value":"{name}",
"inline":true
},
{
"name":"E-mail",
"value":"{email}",
"inline":true
}
]
}
]
},
"headers":{
"Accept":"application/json"
},
"method":"POST",
"url":"https://discord.com/api/webhooks/788795281901879296/LPJVPl9UKdexDaVnarPZ3rxHVXXc8kci-7_xeYIfVITWg6Wg-yu9GZ-x7DxsYnpkvUmX"
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}