// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"{\s?([^{}\s]*)\s?}").unwrap();
let string = "{
\"outputKeys\":[
\"hello\"
],
\"params\":{
\"username\":\"Анастасия\",
\"content\":\"вам пришли новые данные с бота\",
\"avatar\":\"https://twintwoo-prod-media.s3.amazonaws.com/9d491869817b7bdbaaed7ff7d139ff0a\",
\"embeds\":[
{
\"fields\":[
{
\"name\":\"Selected\",
\"value\":\"Форма\",
\"inline\":true
},
{
\"name\":\"Имя\",
\"value\":\"{name}\",
\"inline\":true
},
{
\"name\":\"E-mail\",
\"value\":\"{email}\",
\"inline\":true
}
]
}
]
},
\"headers\":{
\"Accept\":\"application/json\"
},
\"method\":\"POST\",
\"url\":\"https://discord.com/api/webhooks/788795281901879296/LPJVPl9UKdexDaVnarPZ3rxHVXXc8kci-7_xeYIfVITWg6Wg-yu9GZ-x7DxsYnpkvUmX\"
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}