#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?>^.*?ПОДВАЛ|\G)(?(?=КРЫША).*?ПОДВАЛ|.)*?\K(КИРПИЧ)"
Local $sString = "КИРПИЧ ПОДВАЛ дверь КИРПИЧ дверь окно КИРПИЧ КРЫША труба КИРПИЧ ПОДВАЛ дверь КИРПИЧ дверь окно КИРПИЧ КРЫША труба КИРПИЧ"
Local $sSubst = "ПЕНОБЛОК"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)