re = /(?>^.*?ПОДВАЛ|\G)(?(?=КРЫША).*?ПОДВАЛ|.)*?\K(КИРПИЧ)/
str = 'КИРПИЧ ПОДВАЛ дверь КИРПИЧ дверь окно КИРПИЧ КРЫША труба КИРПИЧ ПОДВАЛ дверь КИРПИЧ дверь окно КИРПИЧ КРЫША труба КИРПИЧ'
subst = 'ПЕНОБЛОК'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result