import re
regex = re.compile(r"(?>^.*?ПОДВАЛ|\G)(?(?=КРЫША).*?ПОДВАЛ|.)*?\K(КИРПИЧ)")
test_str = "КИРПИЧ ПОДВАЛ дверь КИРПИЧ дверь окно КИРПИЧ КРЫША труба КИРПИЧ ПОДВАЛ дверь КИРПИЧ дверь окно КИРПИЧ КРЫША труба КИРПИЧ"
subst = "ПЕНОБЛОК"
result = regex.sub(subst, test_str)
if result:
print(result)