const regex = /(?>^.*?ПОДВАЛ|\G)(?(?=КРЫША).*?ПОДВАЛ|.)*?\K(КИРПИЧ)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?>^.*?ПОДВАЛ|\\G)(?(?=КРЫША).*?ПОДВАЛ|.)*?\\K(КИРПИЧ)', 'g')
const str = `КИРПИЧ ПОДВАЛ дверь КИРПИЧ дверь окно КИРПИЧ КРЫША труба КИРПИЧ ПОДВАЛ дверь КИРПИЧ дверь окно КИРПИЧ КРЫША труба КИРПИЧ`;
const subst = `ПЕНОБЛОК`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);