$re = '/(?>^.*?ПОДВАЛ|\G)(?(?=КРЫША).*?ПОДВАЛ|.)*?\K(КИРПИЧ)/';
$str = 'КИРПИЧ ПОДВАЛ дверь КИРПИЧ дверь окно КИРПИЧ КРЫША труба КИРПИЧ ПОДВАЛ дверь КИРПИЧ дверь окно КИРПИЧ КРЫША труба КИРПИЧ';
$subst = "ПЕНОБЛОК";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;