#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(L\d+).* RED"
Local $sString = "Sample text for stackoverflow with value L12345 and some other word like RED." & @CRLF & _
"" & @CRLF & _
"Another text for example with value L54321 and one more BLUE word." & @CRLF & _
"" & @CRLF & _
"Last sample string L11122 and some other RED word."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")