re = /(L\d+).* RED/m
str = 'Sample text for stackoverflow with value L12345 and some other word like RED.
Another text for example with value L54321 and one more BLUE word.
Last sample string L11122 and some other RED word.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end