// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(L\d+).* RED").unwrap();
let string = "Sample text for stackoverflow with value L12345 and some other word like RED.
Another text for example with value L54321 and one more BLUE word.
Last sample string L11122 and some other RED word.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}