$re = '/(L\d+).* RED/m';
$str = 'Sample text for stackoverflow with value L12345 and some other word like RED.
Another text for example with value L54321 and one more BLUE word.
Last sample string L11122 and some other RED word.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);