using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(L\d+).* RED";
string input = @"Sample text for stackoverflow with value L12345 and some other word like RED.
Another text for example with value L54321 and one more BLUE word.
Last sample string L11122 and some other RED word.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}