#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "("|').*?\1(*SKIP)(*FAIL)|\[element(?:[^\[\]]|(?R))*\]"
Local $sString = "[element button text="My button [element image src="adasd"]"]" & @CRLF & _
"" & @CRLF & _
"[element image src="image.png"]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")