using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""|').*?\1(*SKIP)(*FAIL)|\[element(?:[^\[\]]|(?R))*\]";
string input = @"[element button text=""My button [element image src=""adasd""]""]
[element image src=""image.png""]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}