re = /("|').*?\1(*SKIP)(*FAIL)|\[element(?:[^\[\]]|(?R))*\]/
str = '[element button text="My button [element image src="adasd"]"]
[element image src="image.png"]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end