$re = '/("|\').*?\1(*SKIP)(*FAIL)|\[element(?:[^\[\]]|(?R))*\]/';
$str = '[element button text="My button [element image src="adasd"]"]
[element image src="image.png"]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);