import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"|').*?\\1(*SKIP)(*FAIL)|\\[element(?:[^\\[\\]]|(?R))*\\]";
final String string = "[element button text=\"My button [element image src=\"adasd\"]\"]\n\n"
+ "[element image src=\"image.png\"]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}