#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:combine|online|store| |,)+$"
Local $sString = "combine" & @CRLF & _
"combine, online, store" & @CRLF & _
"store online" & @CRLF & _
"online" & @CRLF & _
"combine, anything else" & @CRLF & _
"anything else combine" & @CRLF & _
"combine-online"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")