re = /^(?:combine|online|store| |,)+$/m
str = 'combine
combine, online, store
store online
online
combine, anything else
anything else combine
combine-online'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end