$re = '/^(?:combine|online|store| |,)+$/m';
$str = 'combine
combine, online, store
store online
online
combine, anything else
anything else combine
combine-online';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);