import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:combine|online|store| |,)+$";
final String string = "combine\n"
+ "combine, online, store\n"
+ "store online\n"
+ "online\n"
+ "combine, anything else\n"
+ "anything else combine\n"
+ "combine-online";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}