package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:combine|online|store| |,)+$`)
var str = `combine
combine, online, store
store online
online
combine, anything else
anything else combine
combine-online`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}