#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{3})(?=(?:(?!\d{3}).)*$)"
Local $sString = "TZR9000 Supertroop 2014 001" & @CRLF & _
"FZR Mode 900 Impact 2014 003 Accessories" & @CRLF & _
"NICE750 Destroyer 2014 020" & @CRLF & _
"We like the moon 2013 Stand 010"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")