import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{3})(?=(?:(?!\\d{3}).)*$)";
final String string = "TZR9000 Supertroop 2014 001\n"
+ "FZR Mode 900 Impact 2014 003 Accessories\n"
+ "NICE750 Destroyer 2014 020\n"
+ "We like the moon 2013 Stand 010";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}