use strict;
my $str = 'TZR9000 Supertroop 2014 001
FZR Mode 900 Impact 2014 003 Accessories
NICE750 Destroyer 2014 020
We like the moon 2013 Stand 010';
my $regex = qr~(\d{3})(?=(?:(?!\d{3}).)*$)~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}