$re = '~(\d{3})(?=(?:(?!\d{3}).)*$)~m';
$str = 'TZR9000 Supertroop 2014 001
FZR Mode 900 Impact 2014 003 Accessories
NICE750 Destroyer 2014 020
We like the moon 2013 Stand 010';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);