const regex = new RegExp('(\\d{3})(?=(?:(?!\\d{3}).)*$)', 'gm')
const str = `TZR9000 Supertroop 2014 001
FZR Mode 900 Impact 2014 003 Accessories
NICE750 Destroyer 2014 020
We like the moon 2013 Stand 010`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}