# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d+(?:\.\d+)?(?:px?)?/*/gm;t' <<< "12pxy...12py...12px...12ppx...12...12ypx"