const regex = /\d+(?:\.\d+)?(?:px?)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+(?:\\.\\d+)?(?:px?)?', 'gm')
const str = `12pxy...12py...12px...12ppx...12...12ypx`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);