$re = '/\d+(?:\.\d+)?(?:px?)?/m';
$str = '12pxy...12py...12px...12ppx...12...12ypx';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;