re = /\d+(?:\.\d+)?(?:px?)?/m
str = '12pxy...12py...12px...12ppx...12...12ypx'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result