// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+(?:\.\d+)?(?:px?)?").unwrap();
let string = "12pxy...12py...12px...12ppx...12...12ypx";
let substitution = "*";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}