#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=[?&;])key=.*?($|[&;])"
Local $sString = "http://test.org.uk/v1?key=5d1796deaadcd5d585a7e757897b11a¶m1=value1=¶m2=value2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")