const regex = /(?<=[?&;])key=.*?($|[&;])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[?&;])key=.*?($|[&;])', '')
const str = `http://test.org.uk/v1?key=5d1796deaadcd5d585a7e757897b11a¶m1=value1=¶m2=value2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}