import Foundation
let pattern = #"(?<=[?&;])key=.*?($|[&;])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"http://test.org.uk/v1?key=5d1796deaadcd5d585a7e757897b11a¶m1=value1=¶m2=value2"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}