import re
regex = re.compile(r"(?<=[?&;])key=.*?($|[&;])")
test_str = "http://test.org.uk/v1?key=5d1796deaadcd5d585a7e757897b11a¶m1=value1=¶m2=value2"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")