re = /(?<=[?&;])key=.*?($|[&;])/
str = 'http://test.org.uk/v1?key=5d1796deaadcd5d585a7e757897b11a¶m1=value1=¶m2=value2'
# Print the match result
str.match(re) do |match|
puts match.to_s
end