using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\.)([0-9]{3}\.[0-9]{3}\.[0-9]{3})(?!\.)";
string input = @"Affected IDs:
641.298.855 (this, lead)
213.794.868
948.895.285";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}