import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\.)([0-9]{3}\\.[0-9]{3}\\.[0-9]{3})(?!\\.)";
final String string = "Affected IDs:\n"
+ "641.298.855 (this, lead)\n"
+ "213.794.868\n"
+ "948.895.285";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}